git ssb

1+

mixmix / scuttle-shell



Tree: f73780fddd0bacbf076e4748ba52db49622145cf

Files: f73780fddd0bacbf076e4748ba52db49622145cf / default.nix

721 bytesRaw
1# This file has been generated by node2nix 1.6.0
2# but has been edited to include the systrayhelper
3
4{ pkgs ? import ~/nixpkgs { inherit system; }
5, system ? builtins.currentSystem
6, nodejs ? pkgs."nodejs-8_x"
7, systrayhelper ? pkgs.systrayhelper
8}:
9
10let
11 globalBuildInputs = pkgs.lib.attrValues (import ./supplement.nix {
12 inherit nodeEnv;
13 inherit (pkgs) fetchurl fetchgit;
14 }) ++ [ systrayhelper ];
15 nodeEnv = import ./node-env.nix {
16 inherit (pkgs) stdenv python2 utillinux runCommand writeTextFile;
17 inherit nodejs;
18 libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
19 };
20in
21import ./node-packages.nix {
22 inherit (pkgs) fetchurl fetchgit;
23 inherit nodeEnv globalBuildInputs;
24}

Built with git-ssb-web