Files: e442f556d84d713c6e4ae2a3e49aff43ec0b7831 / default.nix
721 bytesRaw
1 | # This file has been generated by node2nix 1.6.0 |
2 | # but has been edited to include the systrayhelper |
3 | |
4 | { pkgs ? import ~/nixpkgs { inherit system; } |
5 | , system ? builtins.currentSystem |
6 | , nodejs ? pkgs."nodejs-8_x" |
7 | , systrayhelper ? pkgs.systrayhelper |
8 | }: |
9 | |
10 | let |
11 | globalBuildInputs = pkgs.lib.attrValues (import ./supplement.nix { |
12 | inherit nodeEnv; |
13 | inherit (pkgs) fetchurl fetchgit; |
14 | }) ++ [ systrayhelper ]; |
15 | nodeEnv = import ./node-env.nix { |
16 | inherit (pkgs) stdenv python2 utillinux runCommand writeTextFile; |
17 | inherit nodejs; |
18 | libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null; |
19 | }; |
20 | in |
21 | import ./node-packages.nix { |
22 | inherit (pkgs) fetchurl fetchgit; |
23 | inherit nodeEnv globalBuildInputs; |
24 | } |
Built with git-ssb-web