Files: db96b3807c3ddd4b966fe9bfd2014fc57f6913d7 / default.nix
628 bytesRaw
1 | # This file has been generated by node2nix 1.6.0. Do not edit! |
2 | |
3 | {pkgs ? import <nixpkgs> { |
4 | inherit system; |
5 | }, system ? builtins.currentSystem, nodejs ? pkgs."nodejs-8_x"}: |
6 | |
7 | let |
8 | globalBuildInputs = pkgs.lib.attrValues (import ./supplement.nix { |
9 | inherit nodeEnv; |
10 | inherit (pkgs) fetchurl fetchgit; |
11 | }); |
12 | nodeEnv = import ./node-env.nix { |
13 | inherit (pkgs) stdenv python2 utillinux runCommand writeTextFile; |
14 | inherit nodejs; |
15 | libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null; |
16 | }; |
17 | in |
18 | import ./node-packages.nix { |
19 | inherit (pkgs) fetchurl fetchgit; |
20 | inherit nodeEnv globalBuildInputs; |
21 | } |
Built with git-ssb-web