git ssb


cel / ssb-mutual

Feedback of readme:

Closedarj opened this issue on 3/10/2017, 12:31:30 PM

Feedback of readme:

var value =, amount, currency, memo)

Maybe a bit confusing with the word memo, especially as description is used for account. Why not just call it description?

%yZG91PntKHPEwAeTNSRiRqxM5kztTBjg+p6HL/SvbSw=.sha256 cel · 3/10/2017, 2:06:25 PM

yes, memo was supposed to be in the schema. fixed in %Ui/Sz4K....

for account, i was thinking name and description would be updatable using about messages (for which there is an existing convention), as we might want to change the purpose of an account over time. for credit, i didn't think renaming or re-describing would be necessary, as a credit is a one-time event, not something that will be repeatedly transacted with. so i didn't want to use a property that implied that the message should have about messages queried for it to render it.

the property could also be called text instead of memo, to match post and issue schemas, and possible default message renderers. but i was imagining the memo text would be something short, that might fit in a transaction ledger/table, not e.g. whole paragraphs, which i thought a text property might imply.

if "memo" is a confusing term, maybe another one should be used. these documents use the term "For" as the account headings for the ledgers:

or there could be no text field, and we could reply with a post to describe a credit. this project does not use a memo/text field for its transfers:

%aXFlpS8pW8tk7JU0HeR5b3jVqZP60SOylu36xPr8tm4=.sha256 arj closed this issue · 3/12/2017, 12:24:30 PM

Thanks, I think we can leave memo as it is now.

%IC5Lw2bvTuadlgtYNZbL0wePVGnzS/sT0hlMsRjLdvk=.sha256 Dominic · 3/12/2017, 2:43:50 PM

:+1: @cel great explaination of your thought process

Built with git-ssb-web